Алгоритмический язык программирования

Алгоритмизация / Алгоритмический язык программирования

 

Алгоритмический язык программирования — формальный язык, используемый для записи, реализации и изучения алгоритмов. В отличие от большинства языков программирования, алгоритмический язык не привязан к архитектуре компьютера, не содержит деталей, связанных с устройством машины.

Для изучения основ алгоритмизации применяется так называемый Русский алгоритмический язык (школьный алгоритмический язык), использующий понятные школьнику слова на русском языке.

Алголо-подобный алгоритмический язык с русским синтаксисом был введён в употребление академиком А. П. Ершовым в середине 1980-х годов, в качестве основы для "безмашинного" курса информатики.

Основные служебные слова алгоритмического языка

Описание алгоритма

  • алг (алгоритм)
  • арг (аргумент)
  • рез (результат)
  • нач (начало) - начало алгоритма
  • кон (конец) - конец алгоритма
  • дано - исходные данные в произвольной форме
  • надо - цель алгоритма
  • утв

Типы данных:

  • цел (целый)
  • вещ (вещественный)
  • сим (символьный)
  • лит (литера) - строка
  • лог (логический)
  • таб(таблица) - для обозначения массива
  • длин (длина) - количество элементов массива

Обозначение условий

  • если
  • то
  • иначе
  • все
  • выбор
  • при
  • знач

Обозначение циклов

  • нц (начало цикла)
  • кц (конец цикла)
  • пока
  • для
  • от
  • до
  • шаг

Логические функции и значения для составления выражений

  • и
  • или
  • не
  • да
  • нет

Ввод-вывод

  • ввод
  • вывод

 

Общий вид алгоритма

1
2
3
4
5
6
алг название алгоритма (аргументы и результаты)
|  дано условия применимости алгоритма
|  надо цель выполнения алгоритма
нач описание промежуточных величин
|  последовательность команд (тело алгоритма)
кон

 
Часть алгоритма от слова алг до слова нач называется заголовком, а часть, заключенная между словами  нач  и  кон  — телом алгоритма.

В предложении алг после названия алгоритма в круглых скобках указываются характеристики (арг, рез) и тип значения (цел, вещ, сим, лит или лог) всех входных (аргументы) и выходных (результаты) переменных. При описании массивов (таблиц) используется служебное слово таб, дополненное граничными парами по каждому индексу элементов массива.

В записи алгоритма ключевые слова обычно подчёркиваются либо выделяются полужирным шрифтом. Для выделения логических блоков применяются отступы, а парные слова начала и конца блока соединяются вертикальной чертой.

 

Основные алгоритмические структуры

Подробное описание основных алгоритмических структур приведено в этой статье. Ниже приводятся шаблоны составления этих структур на алгоритмическом языке.
Неполная развилка

1
2
3
| если условие
| | то действия
| всё

 
Полная развилка

1
2
3
4
5
| если условие
| | то действия 1
| | иначе действия 2
| всё

 
Ветвление

1
2
3
4
5
6
7
8
| выбор параметр
| | при знач значение 1
| | | действия 1
| | при знач значение 2
| | | действия 2
| | иначе
| | | действия по умолчанию
| всё

 
Цикл с предусловием

1
2
3
| нц пока условие
| | действия
| кц

 
Цикл с постусловием

1
2
3
| нц
| | действия
| кц пока условие

 
Параметрический цикл

1
2
3
| нц для параметр от НЗ до КЗ шаг Ш
| | действия
| кц

Если для выполнения параметрического цикла шаг принимается равным 1, то он может не указываться.

 


Рассмотрим пример составления алгоритма на алгоритмическом языке.
Пример Вычислить сумму квадратов целых чисел от 1 до n.

1
2
3
4
5
6
7
8
9
10
11
алг Сумма квадратов (арг цел n, рез цел S)
| дано n > 0
| надо S = 1*1 + 2*2 + 3*3 + ... + n*n
нач цел i
| ввод n
| S:=0
| нц для i от 1 до n
| | S:=S+i*i
| кц
| вывод "S = ", S
кон

Назад: Алгоритмизация

Комментариев к записи: 2

  • Очень скомкано на мой непритязательный вкус. :с

    Для такого нуба, как я только наглядного примера недостаточно (а тут, по сути, только он и есть). Тем более не хватает некоторых команд.



Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *